Milner Off-Road

The Toyota Landcruiser Owners Club
Landcruiser Club - Dedicated to Toyota Landcruiser, Amazon, Colorado and Prado Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
TLOCUK Club ShopClub Shop  TLOCUK Classified Ads serviceClassified Ads  dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs
TLOCUK HomeTLOCUK Home   TLOCUK ForumsTLOCUK Forums  Click here to link to the South African LandCruiser Owners Club websiteLCCSA  Click here to link to the Australian LandCruiser Owners OnLine website - possibly the longest established Land Cruiser club on the net!LCOOL  Click here to link to the IH8MUD website - run by extremely enthusiastic Land Cruiser owners, with a fantastic source of DIY information and useful forum!IH8MUD

Dashboard lights


 
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 90 Series / Prado / Colorado Technical Forum
View previous topic :: View next topic  
Author Message
mjmcgowan
*


Joined: 08 Jan 2010
Posts: 27
Location: On the Road

PostPosted: Thu Feb 14, 2019 16:10    Post subject: Dashboard lights Reply with quote

The vehicle has been sat around for the last 4-5 months, on starting the vehicle the water in the fuel and low oil light comes on, and the battery light does not turn off (I think is meant to turn off I can't remember)

I have taken out to the fuel filter drained it, the back in and started the vehicle, checked oil levels - all seems fine.

Any ideas on why the lights could come? any reason it can't be driven?

[img]https://imgur.com/a/od1aISS[/img]
_________________
Martin
Back to top
View user's profile Send personal message Visit poster's website
Google
Sponsor





PostPosted: Thu Feb 14, 2019 16:10    Post subject: Google Ads keep this community free to join!


Back to top
andy
Moderator


Joined: 16 Dec 2003
Posts: 1960
Location: Polegate, Sussex, England.

PostPosted: Thu Feb 14, 2019 18:40    Post subject: Reply with quote

Sounds like an alternator fault, so check the output and state of the batteries.
_________________
It's Not a Bl**dy Jeep it's a Landcruiser
100 Series VX Limited
Mercedes Sprinter 311 Luton
1993 VX80 4.2td SOLD
1996 Hilux Surf SSR-G Intercooler Sold
1994 Hilux Surf SSR-V Sold
Back to top
View user's profile Send personal message AIM Address
mjmcgowan
*


Joined: 08 Jan 2010
Posts: 27
Location: On the Road

PostPosted: Thu Feb 14, 2019 18:58    Post subject: Reply with quote

13.5 charge is showing when the vehicle is on,
_________________
Martin
Back to top
View user's profile Send personal message Visit poster's website
DaveWall
******


Joined: 12 Nov 2007
Posts: 893
Location: Gloucestershire

PostPosted: Fri Feb 15, 2019 16:44    Post subject: Reply with quote

What do they read vehicle switched off?
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 90 Series / Prado / Colorado Technical Forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group