Adrian Flux : 01553 845 945

The Toyota Landcruiser Owners Club
Landcruiser Club - Dedicated to Toyota Landcruiser, Amazon, Colorado and Prado Owners
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
TLOCUK Club ShopClub Shop  TLOCUK Classified Ads serviceClassified Ads  dynamic online chat serviceChatrooms  Yellow Diamond ClubsYellow Diamond Clubs
TLOCUK HomeTLOCUK Home   TLOCUK ForumsTLOCUK Forums  Click here to link to the South African LandCruiser Owners Club websiteLCCSA  Click here to link to the Australian LandCruiser Owners OnLine website - possibly the longest established Land Cruiser club on the net!LCOOL  Click here to link to the IH8MUD website - run by extremely enthusiastic Land Cruiser owners, with a fantastic source of DIY information and useful forum!IH8MUD

Bizarre - damp intercooler cladding?!


 
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 100 Series / Amazon Technical Forum
View previous topic :: View next topic  
Author Message
Birchy
*


Joined: 17 Feb 2019
Posts: 13
Location: Hampshire

PostPosted: Wed Mar 20, 2019 18:10    Post subject: Bizarre - damp intercooler cladding?! Reply with quote

Well, I haven't had much luck on here but am hoping you guys can help with this one -

The intercooler pipework has a foam cladding that runs on the bottom of its route under the car, it's U bend I guess you'd call it. This bit if cladding is always wet, and I haven't driven or used the car at all... even after 3 days of dry weather I get underneath it and the cladding is wet to the touch, you squeeze it and it's sodden with water / coolant (Not oil)... what the heck?!

Ben
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Wed Mar 20, 2019 18:10    Post subject: Google Ads keep this community free to join!


Back to top
steven.miles3
Newbie


Joined: 19 Aug 2013
Posts: 6
Location: Torbay

PostPosted: Tue Jun 25, 2019 10:23    Post subject: Reply with quote

Hi Ben,

Is the 'wet' pink? If so it might be your coolant, have you checked the level in the reservoir?
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    The Toyota Landcruiser Owners Club Forum Index -> 100 Series / Amazon Technical Forum All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group